Help: HAPI FHIR: Uploading value sets

Hello~. This is a copy/paste from my questioning in the HAPI Zulip chat:

I am looking for help with uploading value sets to HAPI.

(Note * replaced http with xxxx due to being a new user; the forum only lets new users have 2 hyperlinks per post)

I’m using:

And using this documentation to use the CLI to upload terminology: xxxx://

The CLI’s help text said that it was flexible as to whether I would pass a zip file, or CSV/text, or whatever file of my choice. But I have not had such luck.

Issue #1: ICD-10-CM

It uploaded, but I can’t find any data in the server.
I used this command: hapi-fhir-cli upload-terminology -d ./data/value_sets/LOINC/ -d ./data/value_sets/ICD-10-CM/icd10cm_tabular_2021.xml -v r4 -t http://localhost:8080/fhir -u

I got this success message:

<Parameters xmlns="">
      <name value="success"/>
      <valueBoolean value="true"/>
      <name value="conceptCount"/>
      <valueInteger value="45011"/>
      <name value="target"/>
         <reference value="CodeSystem/1"/>

Here’s some info from xxxx://localhost:8080/fhir/CodeSystem

        "name": "ICD-10-CM",
        "status": "active",
        "content": "not-present"

When I check ConceptMap or ValueSet resources, I get 0 results. Where are these supposed 45011 concepts that were uploaded?

Issue #2: LOINC

I tried uploading some flat files, but got error. I tried some lighter-weight zip files, but it said it was missing all sorts of files. I then tried the 1.5GB zip file.
I ran this command: hapi-fhir-cli upload-terminology -d ./data/value_sets/LOINC/ -d /Users/joeflack4/projects/hapi-fhir-jpaserver-starter/data/value_sets/LOINC/_archive/_Full/ -v r4 -t http://localhost:8080/fhir -u

and this is the abridged version of the error I got: HTTP 400 : Unknown file: hapi-fhir-cli875599

Please only post a question in one place. The best place for this question is either where you first posted it, or the HAPI support group

Sorry Graham! I’m still new to FHIR / HAPI, so I’m not sure the best place for support yet. Where is this HAPI support group, btw? Is this the same as the google group or zulip chat, or something else?

I meant the Google group