Not able to build FHIR ig publisher jar

I am not able to build FHIR ig publisher jar facing issue

when i try to build i got below error.

mvn clean install

[INFO] ------------------------------------------------------------------------
[INFO] Reactor Summary for HL7 FHIR IG Publisher 1.1.14:
[INFO] HL7 FHIR IG Publisher … FAILURE [ 4.094 s]
[INFO] org.hl7.fhir.publisher.core … SKIPPED
[INFO] org.hl7.fhir.publisher.cli … SKIPPED
[INFO] ------------------------------------------------------------------------
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 8.406 s
[INFO] Finished at: 2021-06-01T17:04:17+05:30
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal on project org.hl7.fhir.publisher: Could not resolve dependencies for project org.hl7.fhir.publisher:org.hl7.fhir.publisher:pom:1.1.14: Failed to collect dependencies at ca.uhn.hapi.fhir:org.hl7.fhir.r5:jar:5.1.4 → ca.uhn.hapi.fhir:org.hl7.fhir.utilities:jar:1.1.14: Failed to read artifact descriptor for ca.uhn.hapi.fhir:org.hl7.fhir.utilities:jar:1.1.14: Could not transfer artifact ca.uhn.hapi.fhir:org.hl7.fhir.utilities:pom:1.1.14 from/to bintray-dnault-maven ( Authorization failed for 403 Forbidden → [Help 1]

Build is broken right now - we’re working on it.

The build should be fixed now

Still facing same error.

Issue is not yet resolved . facing same error any update??

I just pulled and build publisher from the master branch with no issues.

Looking at the Azure pipelines, the build appears to be stable and working as of yesterday when the last build for master ran:

This is an issue locally on your machine.

I would try deleting your maven cache and attempting to rebuild. You can also force maven to download new dependencies with the -U tag when you build. Finally, please ensure you don’t have any settings in your ~/.m2/settings.xml file that would conflict with this build (mapping external repos to some other url, or something funky like that).

I hope that helps.

I tried your solution but still getting error.

I’m sorry to hear that Avinash.

As the build is currently working for other users and in our build pipeline, I would assume this is a local problem with your local maven setup. I would look online for reasons why you are not able to pull dependencies properly from Sonatype.

I hope you can get this working, and good luck.