resolve reference Patient/01"

I created an observation resource and referenced the Patient resource with observation.subject. Then I copied it to Members Only - SIMPLIFIER.NET(Members Only - SIMPLIFIER.NET)for validation, but since it references the Patient/01 resource, it prompts me “Incomplete : Cannot resolve reference Patient/01”

due to Members Only - SIMPLIFIER.NET doesn’t storage resource, so I can’t storage patient/01 firstly.
I tried making the Patient/01 and observation resources into a bundle, but it still gives an error.
anyone can help me …

Observation resource like this,
“resourceType” : “Observation”,
“id” : “pr-interval”,
“meta” : {
“profile” : [
“system” : “”,
“value” : “4784228720210317.20210609091715.2”
“status” : “final”,
“category” : [
“coding” : [
“system” : “<status value="active"/> <date value="2022-04-07"/> <publisher value="HL7 International - Cross-Group Projects"/> <contact> <name value="HL7 International - Cross-Group Projects"/> <telecom> <system value="url"/> <value value=""/> </telecom> <telecom> <system value="email"/> <value value=""/> </telecom> </contact> <description value="Set of codes for implementation of the US-Core profiles. These codes are extensions to the [FHIR Observation Category Codes]("/> <jurisdiction> <coding> <system value="urn:iso:std:iso:3166"/> <code value="US"/> </coding> </jurisdiction> <copyright value="Used by permission of HL7 International, all rights reserved Creative Commons License"/> <caseSensitive value="true"/> <content value="complete"/> <count value="1"/> <concept> <code value="clinical-test"/> <display value="Clinical Test"/> <definition value="Includes non-imaging and non-laboratory tests performed on a patient that results in structured or unstructured (narrative) findings specific to the patient, such as electrocardiogram (ECG), visual acuity exam, macular exam, or graded exercise testing (GXT), to facilitate the diagnosis and management of conditions."/> </concept> </CodeSystem>”,
“code” : “clinical-test”,
“display” : “Clinical Test”
“text” : “Clinical Test”
“code” : {
“coding” : [
“system” : “”,
“code” : “8625-6”,
“display” : “P-R interval”
“text” : “P-R interval”
“subject” : {
“reference” : “Patient/01”,
“display” : “ecg patient”
“encounter” : {
“display” : “ecg doctor”
“effectiveDateTime” : “2022-10-03”,
“valueQuantity” : {
“value” : 156,
“unit” : “ms”,
“system” : “”,
“code” : “ms”

Hi @caoteng, thanks for using Simplifier. Let me see if I can help.

First a few answers to questions you did not ask :wink:
I had to make a few changes to be able to copy your resource and have it be valid JSON. This is likely due to pasting it here in this community forum, where regular double quotes were replaced by opening and closing double quotes and escaped double quotes were no longer escaped.
Perhaps share it as a code block next time, or as a Simplifier snippet like this: SIMPLIFIER.NET

Also, when hitting the validation button on that Snippet, you will see two major errors.

  1. The value you have for category.coding.system seems to be some XML representation of part of a US Core CodeSystem? You’d expect the string value there instead.
  2. Because of the above, it does not recognise the category value as the mandatory value with system and value clinical-test.

When we resolve those issues, we are only left with the one you mentioned :slight_smile: (SIMPLIFIER.NET)

You have two options:

  1. You can use Members Only - SIMPLIFIER.NET with a bundle, but the resolving in bundles works such (Bundle - FHIR v4.3.0) that you will need to provide a fullUrl to make sure that the reference resolves. See these snippets where it works:
    • SIMPLIFIER.NET - Where I gave both entries a fullUrl and kept the reference from the Observation relative
    • SIMPLIFIER.NET - Where I gave only the Patient entry a fullUrl and made the reference from the Observation absolute
  2. You can use a Simplifier project for this. Place both the example patient and the example observation in a Simplifier project and make sure in the dependencies of your project you set a dependency on the package of your choice.

Please let me know if that works for you!

Hi @wardweistra, Thanks for your help.

It helped me with this problem and made me more aware of the Bundle.
Thank you again for the detailed explanation.


1 Like